
 T
he first part of this two-part tutorial 

focused on creating a car model suitable 

for use in a next-generation game, using a 

mixture of polygonal and subdivision 

surface techniques. In the file on the CD, additional objects 

such as windscreen wipers and the antenna have been 

added and the shut lines cut out and bevelled to complete 

the model ready for the second part of the tutorial.  

This issue’s walkthrough explores the process of 

texturing, testing and exporting the car. First, to set up the 

scene for UV unwrapping, you will group all panels that will 

be on the same texture sheet and apply a chequered texture, 

so that the flow of the UVs can be seen more easily. Then 

you will UV unwrap all the panels and arrange the UVs onto 

these separate texture sheets. To add realism to a car paint 

shader, an Ambient Occlusion map will be created and edited 

in Photoshop. This map will then be used together with a 

Layered Texture in Maya to blend the Ambient Occlusion map 

with a colour, so that the colour of the vehicle could be 

changed without needing to create multiple colour textures. 

Following this you will create texture maps for front and rear 

lights, adding an alpha channel that will control the reflectivity. 

After the material set-up is complete, the car vehicle can be 

tested with an environment map so that you can see how the 

reflections on its surface might appear in the game.

Finally, the scene will be set up so a game engine would 

be able to ‘read’ all data contained in the file. Specific naming 

conventions will be used, attributes added to group nodes 

and their pivots will be set so that the doors, bonnet and boot 

rotate around their hinge positions correctly. As a last step, 

the scene will be cleaned up to remove its History and any 

unused nodes which may have built up during its creation.

The processes covered in this article are complex and 

game-specific, so it is intended as an overview of the workflow, 

not a complete step-by-step guide. We are also assuming that 

you have some previous Maya experience, although scene 

files are provided on the CD for you to deconstruct.
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● This month’s tutorial takes you 
from untextured model to finished 

in-game asset. Note: the Maya 
file on the CD requires the HDRI 
file building_probe.hdr. You can 

download this for free from  
www.debevec.org/probes by 

clicking the link below ‘Overcast 
Breezeway, Soda Hall’
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FOR
Maya

DIFFICULTY
Intermediate

TIME TAKEN
3–4 days (total)

ON THE CD
•  Full-size screenshots
•  Initial, intermediate and 

final Maya scene files 

ALSO REQUIRED
building_probe.hdr file 
(Free download from 
www.debevec.org/
probes)
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STAGE ONE  |  Creating UV maps

The finished car model from Part One can be found 
on the CD (‘1_Initial File.ma’). It clocks in at slightly 
over 20,000 polygons. To complete it, details like 

windscreen wipers and the antenna were added and the 
shut lines were cut out and bevelled so a smooth edge was 
created on the sides of panels where, for example, the doors 
and fenders and fascias meet.

01
A chequered texture can be used to ensure 
the flow of the UVs is correct and there are no 
texture-stretching artefacts. Create a new Lambert 

material by selecting Assign New Material > Lambert in the 
Lighting/Shading tab of the Rendering menu set. Select the 
new Lambert material and, in the Attribute Editor, connect a 
Checker Render Node to the Color attributes. 

03

Some games may require an Ambient Occlusion 
(AO) map: a texture which controls the amount 
of ambient light each part of a surface receives. 

Combine all objects in the car_body group, ensuring that 
no UVs on this model overlap. Create a plane to act as the 
ground and unhide all other objects. In the Lighting/Shading 
menu, select the options box for ‘Batch Bake (mental ray)’. 

07
In ‘mental ray Baking Options’, use the settings 
above and select Convert to create the Ambient 
Occlusion map. The texture will automatically be 

applied to the surface, which, by default, will be output in the 
folder called project name\renderData\mentalray\lightMap 
with the filename prefixed as per the Prefix field (indicated 
in the screenshot above).

08

It’s important to create a clean UV set so overlay 
textures like dirt and decals can appear on the car’s 
paintwork properly. Select those objects which will 

be using the car paint material and group them using Edit > 
Group. Name the group ‘car_body’ and hide the rest of the 
geometry, so you can select objects to work on more easily, 
by selecting the car_body group and pressing [Alt]+[h].
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STAGE TWO  |  Creating materials

EXPERT TIP
Experimental unwrapping
Experiment with the Cylindrical 
Mapping option, which is ideal for 
unwrapping shapes like the wheels or 
exhaust pipes. New UV unwrapping 
tools are constantly being developed, 
either privately by in-house 
development teams; in official  
updates for Maya; or as freely 
available plug-ins such as Pelt  
(www.digidim.info). New techniques 
like LSCM (Least Squares Conformal 
Mapping) would make texturing 
complex models easier, but for the 
purposes of this tutorial, a series of 
Planar Mapping projections is 
sufficient to lay out the UVs correctly.

i

The Ambient Occlusion map might need to be 
edited, especially for artefacts around aliased 
diagonal lines and around texture edges. Open the 

image in Photoshop and edit the image so the texture edges 
disappear and apply a Gaussian Blur filter in Filter > Blur, 
using a Radius of 1, so the image appears less grainy. 
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Create a rear light texture in a similar way, bearing 
in mind that the alpha channel could control the 
reflectivity. Create a Phong material, name it 

‘mat_Lights_Rear’ and connect the rear light texture to 
the Color channel. For the rear lights it may be necessary 
to create seven separate emissive textures for the various 
permutations of brake, indicator and reverse lights. 

15

The alpha channel will be used to control reflectivity. 
In Photoshop, copy the image to the alpha channel 
and darken it slightly, then save the image under 

a different name. As an initial test in Maya, create a simple 
Lambert material and use the newly created AO map to 
assign it to the Color attribute. Once completed, the map 
applied to the car should look like the image above.
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Create a front light texture from reference photos 
(examples are provided on the CD) and add an alpha 
channel, which will control reflectivity. Create a 

Phong material, name it ‘mat_Lights_Front’ and connect the 
front light texture to the Color channel. Duplicate the texture 
and use the Dodge Tool in Photoshop to create a version that  
could be used as a glow texture, as shown in the lower image.
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STAGE TWO (Continued)  |  Creating materials

A separate material is created for the other parts of 
the car, such as the grille, windscreen wipers, and 
antenna. Arrange the UVs of all those parts which 

will share the texture and create an AO map for them. Use 
this AO map as an Overlay in Photoshop to darken correct 
areas on the texture map. Open up 4_Complete _Scene.ma 
from the CD for a list of all materials used for this vehicle.
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EXPERT TIP
Paint characteristics
We are creating a very simple car paint 
shader for the purposes of this 
tutorial. Developing a ‘real’ car paint 
shader which works realistically in a 
game environment or simulation is 
considerably more complex, as it 
would take into account the different 
paint layers for a base colour, metallic 
look and gloss finish; and the correct 
properties for specularity, reflectivity 
and overlays. Experiment with Maya’s 
samplerInfo node and connect the 
Facing Ratio to a Ramp node to control 
the amount of reflectivity relative to 
the camera’s viewing angle. This is 
known as the Fresnel Effect. 

i

▲

The texture on your model should now appear as 
a black-and-white image, but will be completely 
disordered, as the UVs are not yet laid out properly. 

Select all the objects in the car_body group and apply a 
planar UV projection by selecting the option box in Polygon 
UVs > Planar Mapping and applying Fit to Bounding Box with 
the Mapping Direction set to X Axis as above.
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The front fascia shown in the screenshot above  
is mapped in a similar way to the previous step. 
First, planar map it using the Z Axis setting, then 

select the polygons facing the X Axis, and map them using 
the X Axis setting. The two panels are then joined by scaling 
and aligning them properly, selecting the adjoining edges 
and using the Polygon UVs > Sew UVs tool. 

05

Go around your model using a series of planar 
mappings and manually edit tricky areas by 
selecting the UVs you want to edit and using the  

UV Smudge and UV Lattice features. Lay out the UVs so they 
fit in an area with a 2:1 aspect ratio, so you can later apply 
a 1024x512 texture. After that, scale the UVs so they fit 
within the 0,0 to 1,1 area of the UV window.

06

Select the mat_Paint material and connect the AO 
map to the Reflectivity channel. This will pick up 
the alpha channel of the AO map. You can tweak 

the image in Photoshop to adjust reflectivity or add another 
Layered Texture to control reflectivity using a Ramp node 
combined with a Facing Ratio. Cosine Power can also be 
changed to a higher value, such as 1000. 
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Next, click inside the rectangular area marked in red 
in the image above to add a node to the Layered 
Texture and change the Blend Mode to Multiply. 

Adjust the colour and use the Texture Sample window to see 
the effect of your edits. In this way, the colour properties 
could be changed procedurally without having to create 
multiple image files to simply adjust the car’s colour.
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To create a basic car paint shader, we will be 
using a Layered Texture so that the Color can be a 
combination of the AO map with an adjustable paint 

colour and controlled reflectivity. Create a Phong material, 
name it ‘mat_Paint’ then connect a Layered Texture to the 
Color attribute. In the Attribute Editor, assign the AO map to 
the Color node. Change the Blend Mode to Over.

11
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As a final step, you need to clean up the project and 
remove all unused and unnecessary nodes. To do 
this, first use File > Optimise Scene Size and then 

remove all the History that might have built up over the 
creation process, by using Edit > Delete All by Type > History. 

The specifications for a vehicle in a game environment 
will always be different and are usually defined by the 

technical artists or the programmers on each individual 
project. In this tutorial, we have created a usable vehicle, 
which, although relatively high in poly-count, is solid and 
quite basic in its set-up.

From these starting points, the car could easily be 
adapted for use in virtually any current game engine capable 
of handling the poly and texture budget. ●

22

STAGE THREE  |  Testing and organising the scene for export

To test reflections in the vehicle’s surface, you need 
to apply an environment map. In mental ray’s Render 
Settings, find Image Based Lighting and connect 

a High Dynamic Range (HDR) image to it. This will create a 
sphere onto which the HDR image is mapped and projected 
onto the reflective surface. Note: the scene file on the CD 
requires building_probe.hdr from www.debevec.org/probes.

17
Select all objects and use Modify > Freeze Transforms 
and Modify > Reset Transforms to reset the pivots of 
all objects and to ensure that there are no arbitrary 

transforms on them, as this could make the behaviour of 
game objects inconsistent. Group all objects and name them 
accordingly, as illustrated in the scene file. All objects should 
be neatly moved or combined into separate groups. 

18
It’s important to name all the groups correctly, as 
the game engine might take this information to 
add dynamic attributes to the individual groups. 

Alternatively, you may need to add custom attributes by 
selecting the group and opening the Attribute Editor, then 
selecting Add Attribute in the Attributes > Add Attributes 
tab. For all materials, the prefix ‘mat_’ was used. 

19

Position indicators for effects like smoke, fire, and 
spark particles may be needed. To create a simple 
exhaust smoke locator, for example, create a Locator 

(Create > Locator) and place it at the end of the left exhaust 
pipe. Name it Effect_Exhaust_Left and repeat for the right 
side, naming the locator Effect_Exhaust_Left. 
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Rotation points need to be set so that the doors, 
bonnet and boot rotate correctly. Start by selecting 
the Door_Front_Left group and press [Insert] to 

enter pivot editing mode. Then move the pivot to the hinge 
position of the door. Repeat this step for all doors, the 
bonnet and the boot. For the wheels, use Modify > Center 
Pivot to centre the pivot to wheel position. 
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